Уязвимость BDU:2022-00323

Дата: 11.02.2021. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-00323.

Наименование уязвимости: Уязвимость адаптера PostgreSQL фреймворка rails, связанная с неконтролируемым расходом ресурсов, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость адаптера PostgreSQL фреймворка rails связана с неконтролируемым расходом ресурсов. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Debian GNU/Linux 10.0 | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 1.7 | Прикладное ПО информационных систем Rails Core Team Ruby on Rails от 4.2.0 до 5.2.4.5 | Прикладное ПО информационных систем Rails Core Team Ruby on Rails от 6.0.0 до 6.0.3.5 | Прикладное ПО информационных систем Rails Core Team Ruby on Rails от 6.1.0 до 6.1.2.1 |

Наименование ОС и тип аппаратной платформы: Debian GNU/Linux 80 | Debian GNU/Linux 90 | Debian GNU/Linux 100 | Astra Linux Special Edition 17 |
Дата выявления: 11.02.2021.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:N/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 5)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Для Rails:
использование рекомендаций производителя: https://hackerone.com/reports/1023899

Для Debian:
использование рекомендаций производителя: https://security-tracker.debian.org/tracker/CVE-2021-22880

Для Astra Linux:
использование рекомендаций производителя: https://wiki.astralinux.ru/astra-linux-se17-bulletin-2021-1126SE17
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2021-22880.

Тип ошибки CWE: CWE-400
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://discuss.rubyonrails.org/t/cve-2021-22880-possible-dos-vulnerability-in-active-record-postgresql-adapter/77129
https://hackerone.com/reports/1023899
https://nvd.nist.gov/vuln/detail/CVE-2021-22880
https://security-tracker.debian.org/tracker/CVE-2021-22880
https://wiki.astralinux.ru/astra-linux-se17-bulletin-2021-1126SE17

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.