Уязвимость BDU:2022-01058

Дата: 10.01.2022. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-01058.

Наименование уязвимости: Уязвимость функции storeAtts (xmlparse.c) библиотеки Expat, связанная с целочисленным переполнением, позволяющая нарушителю выполнить произвольный код.

Описание уязвимости: Уязвимость функции storeAtts (xmlparse.c) библиотеки Expat связана с целочисленным переполнением. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, выполнить произвольный код
Уязвимое ПО: Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Debian GNU/Linux 9 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Debian GNU/Linux 10 | Операционная система Novell Inc. OpenSUSE Leap 15.3 | Операционная система Debian GNU/Linux 11 | Прикладное ПО информационных систем James Clark Expat до 2.4.3 |

Наименование ОС и тип аппаратной платформы: Red Hat Enterprise Linux 7 | Debian GNU/Linux 9 | Red Hat Enterprise Linux 8 | Debian GNU/Linux 10 | OpenSUSE Leap 153 | Debian GNU/Linux 11 |
Дата выявления: 10.01.2022.
CVSS 2.0: AV:N/AC:M/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 9,3)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,8)

Возможные меры по устранению:
Использование рекомендаций:
Для библиотеки Expat:
Обновление программного обеспечения до версии 2.4.3 и выше

Для программных продуктов Novell Inc:
https://www.suse.com/security/cve/CVE-2022-22827.html

Для Debian GNU/Linux:
https://security-tracker.debian.org/tracker/CVE-2022-22827

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/cve-2022-22827
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2022-22827.

Тип ошибки CWE: CWE-190
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://www.openwall.com/lists/oss-security/2022/01/17/3
https://github.com/libexpat/libexpat/pull/539
https://www.tenable.com/security/tns-2022-05
https://security-tracker.debian.org/tracker/CVE-2022-22827
https://access.redhat.com/security/cve/cve-2022-22827
https://www.suse.com/security/cve/CVE-2022-22827.html
https://nvd.nist.gov/vuln/detail/CVE-2022-22827
https://safe-surf.ru/upload/VULN/VULN-20220209.18.pdf

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.