Уязвимость BDU:2022-01898

Дата: 22.12.2021. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-01898.

Наименование уязвимости: Уязвимость реализации функции wrap_nettle_hash_fast() криптографической библиотеки GnuTLS, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость реализации функции wrap_nettle_hash_fast() криптографической библиотеки GnuTLS связана с ошибками разыменования указателей. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Novell Inc. Suse Linux Enterprise Server 12 SP5 | Операционная система Novell Inc. SUSE Linux Enterprise Server for SAP Applications 12 SP5 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Software Development Kit 12 SP5 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Real Time Extension 12 SP2 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Basesystem 15 SP3 | Операционная система Novell Inc. OpenSUSE Leap 15.3 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise High Performance Computing 15 SP3 | Операционная система Novell Inc. Suse Linux Enterprise Server 15 SP3 | Операционная система Novell Inc. SUSE Linux Enterprise Server for SAP Applications 15 SP3 | Прикладное ПО информационных систем Novell Inc. SUSE Manager Proxy 4.2 | Прикладное ПО информационных систем Novell Inc. SUSE Manager Server 4.2 | Операционная система Novell Inc. Suse Linux Enterprise Desktop 15 SP3 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Micro 5.0 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Micro 5.1 | Программное средство защиты Free software foundation GnuTLS до 3.7.3 |

Наименование ОС и тип аппаратной платформы: Red Hat Enterprise Linux 8 | Suse Linux Enterprise Server 12 SP5 | SUSE Linux Enterprise Server for SAP Applications 12 SP5 | OpenSUSE Leap 153 | Suse Linux Enterprise Server 15 SP3 | SUSE Linux Enterprise Server for SAP Applications 15 SP3 | Suse Linux Enterprise Desktop 15 SP3 |
Дата выявления: 22.12.2021.
CVSS 2.0: AV:N/AC:L/Au:S/C:N/I:N/A:C
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,8)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,5)

Возможные меры по устранению:
Использование рекомендаций:
Для GnuTLS:
https://gitlab.com/gnutls/gnutls/-/merge_requests/1503

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2021-4209.html

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/cve-2021-4209
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2021-4209.

Тип ошибки CWE: CWE-476
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://www.suse.com/security/cve/CVE-2021-4209.html
https://access.redhat.com/security/cve/cve-2021-4209
https://bugzilla.redhat.com/show_bug.cgi?id=2044156
https://gitlab.com/gnutls/gnutls/-/merge_requests/1503

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.