Уязвимость BDU:2022-02200

Дата: 17.02.2021. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-02200.

Наименование уязвимости: Уязвимость обработчика шаблонов для PHP Smarty, связанная с неверным управлением генерацией кода при обработке недопустимых имен функций, позволяющая нарушителю выполнить произвольный код.

Описание уязвимости: Уязвимость обработчика шаблонов для PHP Smarty связана с неверным управлением генерацией кода при обработке недопустимых имен функций. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, выполнить произвольный код
Уязвимое ПО: Операционная система Debian GNU/Linux 9 | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Canonical Ltd. Ubuntu 21.10 | Прикладное ПО информационных систем New Digital Group, Inc. Smarty до 3.1.39 |

Наименование ОС и тип аппаратной платформы: Debian GNU/Linux 9 | Ubuntu 1804 LTS | Ubuntu 2110 |
Дата выявления: 17.02.2021.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Использование рекомендаций:
Для Smarty:
https://github.com/smarty-php/smarty/blob/master/CHANGELOG.md

Для Debian:
https://lists.debian.org/debian-lts-announce/2021/04/msg00004.html
https://lists.debian.org/debian-lts-announce/2021/04/msg00014.html

Для Ubuntu:
https://ubuntu.com/security/notices/USN-5348-1
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2021-26120.

Тип ошибки CWE: CWE-94
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://nvd.nist.gov/vuln/detail/CVE-2021-26120
https://github.com/smarty-php/smarty/blob/master/CHANGELOG.md
https://lists.debian.org/debian-lts-announce/2021/04/msg00004.html
https://lists.debian.org/debian-lts-announce/2021/04/msg00014.html
https://security.gentoo.org/glsa/202105-06
https://ubuntu.com/security/notices/USN-5348-1

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.