Уязвимость BDU:2022-02235

Дата: 14.07.2021. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-02235.

Наименование уязвимости: Уязвимость библиотеки SSL/TLS WolfSSL, связанная с раскрытием информации через несоответствие, позволяющая нарушителю получить доступ к конфиденциальным данным.

Описание уязвимости: Уязвимость библиотеки SSL/TLS WolfSSL связана с использованием функционала для декодирования base64 с непостоянным временем выполнения. Эксплуатация уязвимости позволяет нарушителю, действующему удаленно, получить доступ к конфиденциальным данным
Уязвимое ПО: Операционная система Debian GNU/Linux 11.0 | Прикладное ПО информационных систем Todd Ouska WolfSSL до 4.6.0 |

Наименование ОС и тип аппаратной платформы: Debian GNU/Linux 110 |
Дата выявления: 14.07.2021.
CVSS 2.0: AV:N/AC:L/Au:S/C:C/I:N/A:N
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,8)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 4,9)

Возможные меры по устранению:
Для WolfSSL:
использование рекомендаций производителя: https://github.com/wolfSSL/wolfssl/releases/tag/v4.8.0-stable

Для Debian:
использование рекомендаций производителя: https://security-tracker.debian.org/tracker/CVE-2021-24116
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2021-24116.

Тип ошибки CWE: CWE-203
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://github.com/UzL-ITS/util-lookup/blob/main/cve-vulnerability-publication.md
https://github.com/wolfSSL/wolfssl/releases/tag/v4.8.0-stable
https://nvd.nist.gov/vuln/detail/CVE-2021-24116
https://security-tracker.debian.org/tracker/CVE-2021-24116

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.