Уязвимость BDU:2022-02242

Дата: 03.09.2021. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-02242.

Наименование уязвимости: Уязвимость функции getrgb библиотеки для работы с растровой графикой Pillow, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции getrgb библиотеки для работы с растровой графикой Pillow связана с неконтролируемым расходом ресурсов. Эксплуатация уязвимости позволяет нарушителю, действующему удаленно, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Debian GNU/Linux 9.0 | Операционная система Debian GNU/Linux 10.0 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система Canonical Ltd. Ubuntu 20.04 LTS | Прикладное ПО информационных систем Red Hat Inc. Red Hat Quay 3 | Операционная система Fedora Project Fedora 33 | Операционная система Canonical Ltd. Ubuntu 21.04 | Операционная система Fedora Project Fedora 34 | Операционная система Canonical Ltd. Ubuntu 16.04 ESM | Операционная система Debian GNU/Linux 11.0 | Операционная система Canonical Ltd. Ubuntu 21.10 | Прикладное ПО информационных систем Uploadcare, LLC Pillow от 5.2.0 до 8.3.2 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1804 LTS | Debian GNU/Linux 90 | Debian GNU/Linux 100 | Ubuntu 1404 ESM | Ubuntu 2004 LTS | Fedora 33 | Ubuntu 2104 | Fedora 34 | Ubuntu 1604 ESM | Debian GNU/Linux 110 | Ubuntu 2110 |
Дата выявления: 03.09.2021.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:N/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Для Pillow:
использование рекомендаций производителя: https://pillow.readthedocs.io/en/stable/releasenotes/8.3.2.html

Для Debian:
использование рекомендаций производителя: https://security-tracker.debian.org/tracker/CVE-2021-23437

Для Ubuntu:
https://ubuntu.com/security/notices/USN-5227-1
https://ubuntu.com/security/notices/USN-5227-2

Для Fedora:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RNSG6VFXTAROGF7ACYLMAZNQV4EJ6I2C/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VKRCL7KKAKOXCVD7M6WC5OKFGL4L3SJT/

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2021-23437
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2021-23437.

Тип ошибки CWE: CWE-125, CWE-400
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://github.com/python-pillow/Pillow/commit/9e08eb8f78fdfd2f476e1b20b7cf38683754866b
https://nvd.nist.gov/vuln/detail/CVE-2021-23437
https://pillow.readthedocs.io/en/stable/releasenotes/8.3.2.html
https://security-tracker.debian.org/tracker/CVE-2021-23437
https://snyk.io/vuln/SNYK-PYTHON-PILLOW-1319443
https://ubuntu.com/security/notices/USN-5227-1
https://ubuntu.com/security/notices/USN-5227-2
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RNSG6VFXTAROGF7ACYLMAZNQV4EJ6I2C/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VKRCL7KKAKOXCVD7M6WC5OKFGL4L3SJT/
https://access.redhat.com/security/cve/CVE-2021-23437

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.