Уязвимость BDU:2022-02401

Дата: 12.09.2016. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-02401.

Наименование уязвимости: Уязвимость функции imagegammacorrect интерпретатора языка программирования PHP , связанная с записью за границами буфера в памяти, позволяющая нарушителю вызвать отказ в обслуживании или, возможно, оказать другое воздействие.

Описание уязвимости: Уязвимость функции imagegammacorrect (ext/gd/gd.c) интерпретатора языка программирования PHP связана с записью за границами буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании или, возможно, оказать другое воздействие
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 12.04 | Прикладное ПО информационных систем PHP Group PHP 7.0.0 | Прикладное ПО информационных систем PHP Group PHP 7.0.7 | Операционная система Debian GNU/Linux 9 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система Debian GNU/Linux 8 | Операционная система Debian GNU/Linux 10 | Операционная система Canonical Ltd. Ubuntu 16.04 ESM | Операционная система Debian GNU/Linux 11 | Прикладное ПО информационных систем PHP Group PHP 7.0.4 | Прикладное ПО информационных систем PHP Group PHP 7.0.5 | Прикладное ПО информационных систем PHP Group PHP 7.0.8 | Прикладное ПО информационных систем PHP Group PHP 7.0.9 | Прикладное ПО информационных систем PHP Group PHP 7.0.6 | Прикладное ПО информационных систем PHP Group PHP 7.0.2 | Прикладное ПО информационных систем PHP Group PHP 7.0.3 | Прикладное ПО информационных систем PHP Group PHP до 5.6.24 включительно |

Наименование ОС и тип аппаратной платформы: Ubuntu 1204 32-bit | Debian GNU/Linux 9 | Ubuntu 1404 ESM | Debian GNU/Linux 8 | Debian GNU/Linux 10 | Ubuntu 1604 ESM | Debian GNU/Linux 11 |
Дата выявления: 12.09.2016.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Использование рекомендаций:
https://github.com/php/php-src/commit/1bd103df00f49cf4d4ade2cfe3f456ac058a4eae?w=1

Для Ubuntu
https://ubuntu.com/security/CVE-2016-7127

Для Debian GNU/Linux:
https://security-tracker.debian.org/tracker/CVE-2016-7127.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2016-7127.

Тип ошибки CWE: CWE-787
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://www.php.net/ChangeLog-7.php
http://openwall.com/lists/oss-security/2016/09/02/9
http://www.php.net/ChangeLog-5.php
https://bugs.php.net/bug.php?id=72730
https://github.com/php/php-src/commit/1bd103df00f49cf4d4ade2cfe3f456ac058a4eae?w=1
http://www.securityfocus.com/bid/92757
https://security.gentoo.org/glsa/201611-22
http://www.securitytracker.com/id/1036680
https://www.tenable.com/security/tns-2016-19
http://rhn.redhat.com/errata/RHSA-2016-2750.html

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.