Уязвимость BDU:2022-02419

Дата: 10.07.2017. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-02419.

Наименование уязвимости: Уязвимость функции wddx_deserialize() интерпретатора языка программирования PHP , связанная с использованием памяти после её освобождения, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость интерпретатора языка программирования PHP связана с недостатками механизма десериализации. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 12.04 | Операционная система Canonical Ltd. Ubuntu 17.04 | Операционная система Debian GNU/Linux 9 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система Debian GNU/Linux 8 | Операционная система Debian GNU/Linux 7.0 | Операционная система Canonical Ltd. Ubuntu 16.04 ESM | Прикладное ПО информационных систем PHP Group PHP до 5.6.30 включительно |

Наименование ОС и тип аппаратной платформы: Ubuntu 1204 32-bit | Ubuntu 1704 | Debian GNU/Linux 9 | Ubuntu 1404 ESM | Debian GNU/Linux 8 | Debian GNU/Linux 70 | Ubuntu 1604 ESM |
Дата выявления: 10.07.2017.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:N/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
https://git.php.net/?p=php-src.git;a=commit;h=2aae60461c2ff7b7fbcdd194c789ac841d0747d7

https://bugs.php.net/bug.php?id=74145

http://php.net/ChangeLog-5.php

http://openwall.com/lists/oss-security/2017/07/10/6

Для Ubuntu
https://ubuntu.com/security/CVE-2017-11143

Для Debian GNU/Linux:
https://security-tracker.debian.org/tracker/CVE-2017-11143.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2017-11143.

Тип ошибки CWE: CWE-416
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://git.php.net/?p=php-src.git;a=commit;h=2aae60461c2ff7b7fbcdd194c789ac841d0747d7
https://bugs.php.net/bug.php?id=74145
http://php.net/ChangeLog-5.php
http://openwall.com/lists/oss-security/2017/07/10/6
http://www.securityfocus.com/bid/99553
https://www.tenable.com/security/tns-2017-12
https://www.debian.org/security/2018/dsa-4081
https://security.netapp.com/advisory/ntap-20180112-0001/
https://access.redhat.com/errata/RHSA-2018:1296

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.