Уязвимость BDU:2022-03968

Дата: 03.07.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-03968.

Наименование уязвимости: Уязвимость компонента fs/xfs/libxfs/xfs_inode_buf.c файловой системы XFS ядра операционной системы Linux, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость компонента fs/xfs/libxfs/xfs_inode_buf.c файловой системы XFS ядра операционной системы Linux связана с записью за границами буфера в памяти. Эксплуатация уязвимости может позволить нарушителю вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Debian GNU/Linux 9.0 | Прикладное ПО информационных систем Red Hat Inc. Red Hat Enterprise MRG 2.0 | Операционная система Debian GNU/Linux 10.0 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система Canonical Ltd. Ubuntu 16.04 ESM | Операционная система Debian GNU/Linux 11.0 | Операционная система Linux до 4.18-RC3 | Операционная система Linux до 5.19-rc4 |

Наименование ОС и тип аппаратной платформы: Red Hat Enterprise Linux 7 | Ubuntu 1804 LTS | Debian GNU/Linux 90 | Debian GNU/Linux 100 | Ubuntu 1404 ESM | Ubuntu 1604 ESM | Debian GNU/Linux 110 | Linux до 418-RC3 | Linux до 519-rc4 |
Дата выявления: 03.07.2018.
CVSS 2.0: AV:L/AC:L/Au:N/C:N/I:N/A:C
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,9)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,5)

Возможные меры по устранению:
Использование рекомендаций:
Для Linux:
https://git.kernel.org/pub/scm/fs/xfs/xfs-linux.git/commit/?h=for-next&id=23fcb3340d033d9f081e21e6c12c2db7eaa541d3

Для Debian GNU/Linux:
https://security-tracker.debian.org/tracker/CVE-2018-13095

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2018-13095

Для Ubuntu:
https://ubuntu.com/security/notices/USN-4904-1
https://ubuntu.com/security/notices/USN-4907-1
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-13095.

Тип ошибки CWE: CWE-787
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://git.kernel.org/pub/scm/fs/xfs/xfs-linux.git/commit/?h=for-next&id=23fcb3340d033d9f081e21e6c12c2db7eaa541d3
https://security-tracker.debian.org/tracker/CVE-2018-13095
https://access.redhat.com/security/cve/CVE-2018-13095
https://ubuntu.com/security/notices/USN-4904-1
https://ubuntu.com/security/notices/USN-4907-1
https://github.com/torvalds/linux/commit/23fcb3340d033d9f081e21e6c12c2db7eaa541d3

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *