Уязвимость BDU:2022-04165

Дата: 08.06.2022. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-04165.

Наименование уязвимости: Уязвимость пакета keep языка программирования Python, позволяющая нарушителю выполнить произвольный код.

Описание уязвимости: Уязвимость пакета keep языка программирования Python связана с наличием вредоносной зависимости «request» (без s). Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, выполнить произвольный код
Уязвимое ПО: Сетевое средство, Прикладное ПО информационных систем, Сетевое программное средство keep 1.2 |

Наименование ОС и тип аппаратной платформы:
Дата выявления: 08.06.2022.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Обновить пакет keep до акутальной версии
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2022-30877.

Тип ошибки CWE: CWE-912
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://pypi.doubanio.com/simple/request
https://github.com/OrkoHunter/keep/issues/85
https://pypi.org/project/keep
https://www.securitylab.ru/news/532253.php

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *