Уязвимость BDU:2022-04361

Дата: 14.04.2022. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-04361.

Наименование уязвимости: Уязвимость утилиты определения версий пакетов npm-dependency-versions пакетного менеджера NPM, позволяющая науршителю выполнить произвольную команду.

Описание уязвимости: Уязвимость утилиты определения версий пакетов npm-dependency-versions пакетного менеджера NPM связана с недостаточной проверкой аргументов, передаваемых в команду. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, выполнить произвольную команду
Уязвимое ПО: Прикладное ПО информационных систем npm-dependency-versions до 0.3.0 включительно |

Наименование ОС и тип аппаратной платформы:
Дата выявления: 14.04.2022.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Организационные меры:
1. Ограничить использование программного средства
2. Использование аналогичного программного средства
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Информация об устранении отсутствует
Идентификаторы других систем описаний уязвимости: CVE-2022-29080.

Тип ошибки CWE: CWE-77
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://github.com/barneycarroll/npm-dependency-versions/issues/6
https://www.npmjs.com/package/npm-dependency-versions

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *