Уязвимость BDU:2022-04488

Дата: 06.05.2022. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-04488.

Наименование уязвимости: Уязвимость функции njs_vmcode_interpreter (src/njs_vmcode.c) интерпретатора njs сервера nginx, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции njs_vmcode_interpreter (src/njs_vmcode.c) интерпретатора njs сервера nginx связана с неконтролируемым расходом ресурсов. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании
Уязвимое ПО: Прикладное ПО информационных систем NGINX Inc. njs до 0.7.6 |

Наименование ОС и тип аппаратной платформы:
Дата выявления: 06.05.2022.
CVSS 2.0: AV:A/AC:M/Au:S/C:P/I:P/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,9)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,5)

Возможные меры по устранению:
Использование рекомендаций:
https://github.com/nginx/njs/commit/31ed93a5623f24ca94e6d47e895ba735d9d97d46
https://github.com/nginx/njs/issues/483
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2022-32414.

Тип ошибки CWE: CWE-400
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://vuldb.com/?id.202446
https://github.com/nginx/njs/commit/31ed93a5623f24ca94e6d47e895ba735d9d97d46
https://github.com/nginx/njs/issues/483
https://nvd.nist.gov/vuln/detail/CVE-2022-32414

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *