Уязвимость BDU:2022-04497

Дата: 18.07.2022. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-04497.

Наименование уязвимости: Уязвимость функции njs_scope_value() (njs_scope.h) интерпретатора njs сервера nginx, позволяющие нарушителю выполнить произвольный код.

Описание уязвимости: Уязвимость функции njs_scope_value() (njs_scope.h) интерпретатора njs сервера nginx связана с чтением данных за границами буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, выполнить произвольный код
Уязвимое ПО: Прикладное ПО информационных систем NGINX Inc. njs до 0.7.6 |

Наименование ОС и тип аппаратной платформы:
Дата выявления: 18.07.2022.
CVSS 2.0: AV:N/AC:L/Au:N/C:P/I:P/A:P
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,5)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,3)

Возможные меры по устранению:
Обновление программного обеспечения до версии 0.7.6 и выше
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2022-34029.

Тип ошибки CWE: CWE-125
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://vuldb.com/ru/?id.204148
https://github.com/nginx/njs/issues/506

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *