Уязвимость BDU:2022-05231

Дата: 14.01.2021. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-05231.

Наименование уязвимости: Уязвимость инструмент Java-to-XML Apache XMLBeans, связанная с ошибками при обработке XML-сущностей, позволяющая нарушителю вызвать отказ в обслуживании или раскрыть защищаемую информацию.

Описание уязвимости: Уязвимость инструмент Java-to-XML Apache XMLBeans связана с ошибками при обработке XML-сущностей. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании или раскрыть защищаемую информацию
Уязвимое ПО: ПО виртуализации/ПО виртуального программно-аппаратного средства Oracle Corp. Fusion Middleware 12.2.1.3.0 | Прикладное ПО информационных систем Oracle Corp. PeopleSoft Enterprise PeopleTools 8.57 | Операционная система Debian GNU/Linux 9.0 | ПО виртуализации/ПО виртуального программно-аппаратного средства Oracle Corp. Fusion Middleware 12.2.1.4.0 | Прикладное ПО информационных систем Oracle Corp. PeopleSoft Enterprise PeopleTools 8.58 | Прикладное ПО информационных систем Oracle Corp. PeopleSoft Enterprise PeopleTools 8.59 | Прикладное ПО информационных систем Apache Software Foundation XMLBeans до 2.6.0 включительно | Прикладное ПО информационных систем IBM Corp. IBM Sterling B2B Integrator от 6.1.0.0 до 6.1.0.2 включительно | Прикладное ПО информационных систем IBM Corp. IBM Sterling B2B Integrator от 6.0.0.0 до 6.0.0.6 включительно | Прикладное ПО информационных систем IBM Corp. IBM Sterling B2B Integrator от 6.0.1.0 до 6.0.3.4 включительно | Прикладное ПО информационных систем IBM Corp. IBM Sterling B2B Integrator от 5.2.0.0 до 5.2.6.5_4 включительно |

Наименование ОС и тип аппаратной платформы: Debian GNU/Linux 90 |
Дата выявления: 14.01.2021.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:N/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 9,4)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,1)

Возможные меры по устранению:
Использование рекомендаций:
Для XMLBeans:
https://www.ibm.com/support/pages/node/6495963

Для программных продуктов Apache Software Foundation:
https://issues.apache.org/jira/browse/XMLBEANS-517
https://lists.apache.org/thread.html/r2dc5588009dc9f0310b7382269f932cc96cae4c3901b747dda1a7fed@%3Cjava-dev.axis.apache.org%3E
https://lists.apache.org/thread.html/rbb01d10512098894cd5f22325588197532c64f1c818ea7e4120d40c1@%3Cjava-dev.axis.apache.org%3E

Для Debian GNU/Linux:
https://lists.debian.org/debian-lts-announce/2021/06/msg00024.html

Для программных продуктов Oracle Corp.:
https://www.oracle.com/security-alerts/cpujul2022.html
https://www.oracle.com/security-alerts/cpuoct2021.html
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2021-23926.

Тип ошибки CWE: CWE-776
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://www.ibm.com/support/pages/node/6495963
https://issues.apache.org/jira/browse/XMLBEANS-517
https://lists.apache.org/thread.html/r2dc5588009dc9f0310b7382269f932cc96cae4c3901b747dda1a7fed@%3Cjava-dev.axis.apache.org%3E
https://lists.apache.org/thread.html/rbb01d10512098894cd5f22325588197532c64f1c818ea7e4120d40c1@%3Cjava-dev.axis.apache.org%3E
https://lists.debian.org/debian-lts-announce/2021/06/msg00024.html
https://www.oracle.com/security-alerts/cpujul2022.html
https://www.oracle.com/security-alerts/cpuoct2021.html

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *