Уязвимость BDU:2022-05350

Дата: 27.02.2022. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-05350.

Наименование уязвимости: Уязвимость функции php_filter_float() интерпретатора языка программирования PHP, позволяющая нарушителю выполнить произвольный код.

Описание уязвимости: Уязвимость функции php_filter_float() интерпретатора языка программирования PHP связана с ошибкой использования памяти после ее освобождения. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, выполнить произвольный код
Уязвимое ПО: Операционная система Novell Inc. SUSE Linux Enterprise Server for SAP Applications 12 SP3 | Операционная система Novell Inc. SUSE Linux Enterprise Server for SAP Applications 12 SP4 | Операционная система Novell Inc. Suse Linux Enterprise Server 12 SP3 | Операционная система Novell Inc. Suse Linux Enterprise Server 12 SP4 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Debian GNU/Linux 10.0 | Операционная система Novell Inc. Suse Linux Enterprise Server 12 SP5 | Операционная система Novell Inc. SUSE Linux Enterprise Server for SAP Applications 12 SP5 | Операционная система Novell Inc. SUSE Linux Enterprise Server for SAP Applications 12 | Операционная система Canonical Ltd. Ubuntu 20.04 LTS | Операционная система Novell Inc. OpenSUSE Leap 15.3 | Операционная система Debian GNU/Linux 11.0 | Операционная система Canonical Ltd. Ubuntu 21.10 | Операционная система Novell Inc. Suse Linux Enterprise Server 12 | Операционная система ООО «Ред Софт» РЕД ОС 7.3 | Операционная система Novell Inc. OpenSUSE Leap 15.4 | Операционная система Novell Inc. Suse Linux Enterprise Server 15 SP3 | Операционная система Novell Inc. SUSE Linux Enterprise Server for SAP Applications 15 SP3 | Операционная система Novell Inc. SUSE Linux Enterprise Server for SAP Applications 15 SP2 | Операционная система АО «ИВК» Альт 8 СП — | Операционная система Novell Inc. Suse Linux Enterprise Server 15 SP4 | Операционная система Novell Inc. Suse Linux Enterprise Server 15 SP2-BCL | Операционная система Novell Inc. SUSE Linux Enterprise Server for SAP Applications 15 SP4 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 9 | Операционная система Novell Inc. Suse Linux Enterprise Server 15 SP2-LTSS | Прикладное ПО информационных систем PHP Group PHP от 7.4.0 до 7.4.28 | Прикладное ПО информационных систем PHP Group PHP от 8.0.0 до 8.0.16 | Прикладное ПО информационных систем PHP Group PHP от 8.1.0 до 8.1.3 |

Наименование ОС и тип аппаратной платформы: SUSE Linux Enterprise Server for SAP Applications 12 SP3 | SUSE Linux Enterprise Server for SAP Applications 12 SP4 | Suse Linux Enterprise Server 12 SP3 | Suse Linux Enterprise Server 12 SP4 | Red Hat Enterprise Linux 8 | Debian GNU/Linux 100 | Suse Linux Enterprise Server 12 SP5 | SUSE Linux Enterprise Server for SAP Applications 12 SP5 | SUSE Linux Enterprise Server for SAP Applications 12 | Ubuntu 2004 LTS | OpenSUSE Leap 153 | Debian GNU/Linux 110 | Ubuntu 2110 | Suse Linux Enterprise Server 12 | РЕД ОС 73 | OpenSUSE Leap 154 | Suse Linux Enterprise Server 15 SP3 | SUSE Linux Enterprise Server for SAP Applications 15 SP3 | SUSE Linux Enterprise Server for SAP Applications 15 SP2 | Альт 8 СП — | Suse Linux Enterprise Server 15 SP4 | Suse Linux Enterprise Server 15 SP2-BCL | SUSE Linux Enterprise Server for SAP Applications 15 SP4 | Red Hat Enterprise Linux 9 | Suse Linux Enterprise Server 15 SP2-LTSS |
Дата выявления: 27.02.2022.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Использование рекомендаций:
Для PHP:
https://bugs.php.net/bug.php?id=81708

Для Debian GNU/Linux:
https://security-tracker.debian.org/tracker/CVE-2021-21708

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2021-21708

Для РЕД ОС:
https://redos.red-soft.ru/support/secure/uyazvimosti/mnozhestvennye-uyazvimosti-php-cve-2021-21708-cve-2022-31625-cve-2021-21702-cve-2021-21705-cve-2021-/
http://repo.red-soft.ru/redos/7.3c/x86_64/updates/

Для ОС Альт 8 СП:
установка обновления из публичного репозитория программного средства

Для Ubuntu:
https://ubuntu.com/security/CVE-2021-21708
https://ubuntu.com/security/notices/USN-5303-1

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2021-21708.html
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2021-21708.

Тип ошибки CWE: CWE-416
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://bugs.php.net/bug.php?id=81708
https://security.netapp.com/advisory/ntap-20220325-0004/
https://security-tracker.debian.org/tracker/CVE-2021-21708
https://access.redhat.com/security/cve/CVE-2021-21708
https://redos.red-soft.ru/support/secure/uyazvimosti/mnozhestvennye-uyazvimosti-php-cve-2021-21708-cve-2022-31625-cve-2021-21702-cve-2021-21705-cve-2021-/
http://repo.red-soft.ru/redos/7.3c/x86_64/updates/
https://altsp.su/obnovleniya-bezopasnosti/
https://security.gentoo.org/glsa/202209-20
https://ubuntu.com/security/CVE-2021-21708
https://ubuntu.com/security/notices/USN-5303-1
https://www.suse.com/security/cve/CVE-2021-21708.html

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *