Уязвимость BDU:2022-05766

Дата: 17.12.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-05766.

Наименование уязвимости: Уязвимость функции calculate_gain компонента libfaad/sbr_hfadj.c аудио декодера Freeware Advanced Audio Decoder 2 (FAAD2), позволяющая нарушителю получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции calculate_gain компонента libfaad/sbr_hfadj.c аудио декодера Freeware Advanced Audio Decoder 2 (FAAD2) связана с отсутствием сравнения с MAX_M. Эксплуатация уязвимости позволяет нарушителю, действующему удаленно, получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Debian GNU/Linux 10 | Операционная система Debian GNU/Linux 11 | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 1.7 | Прикладное ПО информационных систем Freeware Advanced Audio Decoder 2 2.8.8 | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 4.7 | Операционная система АО “НППКТ” ОСОН ОСнова Оnyx до 2.1 |

Наименование ОС и тип аппаратной платформы: Debian GNU/Linux 10 | Debian GNU/Linux 11 | Astra Linux Special Edition 17 | Astra Linux Special Edition 47 ARM | ОСОН ОСнова Оnyx до 21 |
Дата выявления: 17.12.2018.
CVSS 2.0: AV:N/AC:M/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 9,3)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,8)

Возможные меры по устранению:
Для Freeware Advanced Audio Decoder 2 (FAAD2):
использование рекомендаций производителя: https://github.com/knik0/faad2/commit/6aeeaa1af0caf986daf22852a97f7c13c5edd879

Для Debian:
использование рекомендаций производителя: https://security-tracker.debian.org/tracker/CVE-2018-20196

Для ОС Astra Linux:
использование рекомендаций производителя:
https://wiki.astralinux.ru/astra-linux-se47-bulletin-2022-0926SE47
https://wiki.astralinux.ru/astra-linux-se17-bulletin-2022-0819SE17

Для ОСОН Основа:
Обновление программного обеспечения faad2 до версии 2.10.0+repack-1.osnova1.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-20196.

Тип ошибки CWE: CWE-787
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://github.com/knik0/faad2/commit/6aeeaa1af0caf986daf22852a97f7c13c5edd879
https://github.com/knik0/faad2/issues/19
https://nvd.nist.gov/vuln/detail/CVE-2018-20196
https://security-tracker.debian.org/tracker/CVE-2018-20196
https://wiki.astralinux.ru/astra-linux-se47-bulletin-2022-0926SE47
https://wiki.astralinux.ru/astra-linux-se17-bulletin-2022-0819SE17
https://поддержка.нппкт.рф/bin/view/ОСнова/Обновления/2.1/

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *