Уязвимость BDU:2022-06074

Дата: 31.05.2010. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-06074.

Наименование уязвимости: Уязвимость реализации класса преобразования выражений OGNL (Object-Graph Navigation Language) структуры шаблонов команд XWork программной платформы Apache Struts, позволяющая нарушителю обойти ограничения безопасности и выполнить произвольные команды.

Описание уязвимости: Уязвимость реализации класса преобразования выражений OGNL (Object-Graph Navigation Language) структуры шаблонов команд XWork программной платформы Apache Struts связана с недостатками разграничения доступа при использовании класса ParametersInterceptor с параметром #. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, обойти ограничения безопасности и выполнить произвольные команды с помощью специально созданных объектов #context, #_memberAccess, #root, #this, #_typeResolver, #_classResolver, #_traceEvaluations, #_lastEvaluation, #_keepLastEvaluation
Уязвимое ПО: Прикладное ПО информационных систем IBM Corp. IBM Call Center for Commerce 9.5.0 | Прикладное ПО информационных систем IBM Corp. IBM Call Center for Commerce 10.0 | Сетевое программное средство Apache Software Foundation Apache Struts от 2.0.0 до 2.1.8.1 включительно | Прикладное ПО информационных систем Atlassian Fisheye до 2.3.2 включительно | Прикладное ПО информационных систем Atlassian Crucible до 2.3.2 включительно | ПО сетевого программно-аппаратного средства Cisco Systems Inc. Cisco Identity Services Engine до 1.0.4.573-6 | ПО сетевого программно-аппаратного средства Cisco Systems Inc. Cisco Identity Services Engine от 1.1.0.665 до 1.1.0.665-4 | ПО сетевого программно-аппаратного средства Cisco Systems Inc. Cisco Identity Services Engine от 1.1.1.268 до 1.1.1.268-6 | ПО сетевого программно-аппаратного средства Cisco Systems Inc. Cisco Identity Services Engine от 1.1.2.145 до 1.1.2.145-9 | ПО сетевого программно-аппаратного средства Cisco Systems Inc. Cisco Identity Services Engine от 1.1.3.124 до 1.1.3.124-4 | ПО сетевого программно-аппаратного средства Cisco Systems Inc. Cisco Identity Services Engine от 1.1.4.218 до 1.1.4.218-4 | ПО сетевого программно-аппаратного средства Cisco Systems Inc. Cisco Identity Services Engine от 1.2.0.0 до 1.2.0.899 | Сетевое программное средство Cisco Systems Inc. Cisco Unified Contact Center Enterprise от 10.5 до 10.5(1) | Сетевое программное средство Cisco Systems Inc. Cisco Unified Contact Center Enterprise от 8.5(4) до 8.5(4)ES37 | Сетевое программное средство Cisco Systems Inc. Cisco Unified Contact Center Enterprise от 9.0(4) до 9.0(4)ES39 | Сетевое программное средство Cisco Systems Inc. Cisco Unified Contact Center Enterprise от 9.0(3) до 9.0(3)ES13 | Сетевое средство, ПО сетевого программно-аппаратного средства Cisco Systems Inc. Cisco Media Experience Engine (MXE) 3500 Series до 3.3.2 |

Наименование ОС и тип аппаратной платформы:
Дата выявления: 31.05.2010.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:P/A:N
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 5)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,8)

Возможные меры по устранению:
Использование рекомендаций:
Для Apache Struts:
https://cwiki.apache.org/confluence/display/WW/S2-005

Для программных продуктов Atlassian:
https://confluence.atlassian.com/fisheye/fisheye-security-advisory-2010-06-16-960161732.html

Для программных продуктов IBM:
https://www.ibm.com/blogs/psirt/security-bulletin-ibm-call-center-and-apache-struts-struts-upgrade-strategy-various-cves-see-below/

Для программных продуктов Cisco:
http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20140709-struts2

Компенсирующие меры:
Следующая дополнительная конфигурация interceptor-ref поможет исключить вредоносные параметры:

<interceptor-ref name="params">
<param name="excludeParams">dojo..*,^struts..*,.*\.*,.*(.*,.*).*,.*@.*</param>
</interceptor-ref>
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2010-1870.

Тип ошибки CWE: CWE-264
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://confluence.atlassian.com/fisheye/fisheye-security-advisory-2010-06-16-960161732.html
https://www.ibm.com/blogs/psirt/security-bulletin-ibm-call-center-and-apache-struts-struts-upgrade-strategy-various-cves-see-below/
https://nvd.nist.gov/vuln/detail/CVE-2010-1870
https://cwiki.apache.org/confluence/display/WW/S2-005
https://seclists.org/fulldisclosure/2010/Jul/183
http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20140709-struts2

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *