Уязвимость BDU:2022-06075

Дата: 09.06.2013. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-06075.

Наименование уязвимости: Уязвимость реализации класса преобразования выражений OGNL (Object-Graph Navigation Language) программной платформы Apache Struts, позволяющая нарушителю выполнить произвольный код.

Описание уязвимости: Уязвимость реализации класса преобразования выражений OGNL (Object-Graph Navigation Language) программной платформы Apache Struts связана с неверным управлением генерацией кода. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, выполнить произвольный код путем отправки специально созданного запроса
Уязвимое ПО: Программное средство защиты Oracle Corp. WebCenter Sites 11.1.1.8.0 | Прикладное ПО информационных систем Oracle Corp. Oracle FLEXCUBE Private Banking 2.2.0.1 | Прикладное ПО информационных систем Oracle Corp. Oracle FLEXCUBE Private Banking 12.0.1.0 | Программное средство защиты Oracle Corp. WebCenter Sites 11.1.1.6.1 | Сетевое программное средство Apache Software Foundation Apache Struts от 2.0.0 до 2.3.14.3 | Прикладное ПО информационных систем Oracle Corp. Oracle FLEXCUBE Private Banking 1.7 | Прикладное ПО информационных систем Oracle Corp. Oracle FLEXCUBE Private Banking 2.0 | Прикладное ПО информационных систем Oracle Corp. Oracle FLEXCUBE Private Banking 2.0.1 | Прикладное ПО информационных систем Oracle Corp. Oracle FLEXCUBE Private Banking 3.0 | Прикладное ПО информационных систем Oracle Corp. Oracle FLEXCUBE Private Banking 12.0.2 | Сетевое программное средство Oracle Corp. MySQL Enterprise Monitor до 2.3.14 включительно | Сетевое программное средство Oracle Corp. MySQL Enterprise Monitor от 3.0.0 до 3.0.4 включительно | Прикладное ПО информационных систем IBM Corp. IBM Call Center for Commerce 9.5.0 | Прикладное ПО информационных систем IBM Corp. IBM Call Center for Commerce 10.0 |

Наименование ОС и тип аппаратной платформы:
Дата выявления: 09.06.2013.
CVSS 2.0: AV:N/AC:M/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 9,3)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,6)

Возможные меры по устранению:
Использование рекомндаций:
Для Apache Struts:
https://cwiki.apache.org/confluence/display/WW/S2-015

Для программных продуктов IBM Corp.:
https://www.ibm.com/blogs/psirt/security-bulletin-ibm-call-center-and-apache-struts-struts-upgrade-strategy-various-cves-see-below/

Для программных продуктов Oracle:
https://www.oracle.com/security-alerts/cpujan2014.html
https://www.oracle.com/security-alerts/cpuoct2013.html
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2013-2134.

Тип ошибки CWE: CWE-94
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://www.ibm.com/blogs/psirt/security-bulletin-ibm-call-center-and-apache-struts-struts-upgrade-strategy-various-cves-see-below/
https://cwiki.apache.org/confluence/display/WW/S2-015
http://www.oracle.com/technetwork/topics/security/cpujan2014-1972949.html
http://www.oracle.com/technetwork/topics/security/cpuoct2013-1899837.html
https://nvd.nist.gov/vuln/detail/CVE-2013-2134

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *