Уязвимость BDU:2022-06449

Дата: 19.07.2022. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-06449.

Наименование уязвимости: Уязвимость функции gst_avi_demux_invert мультимедийного фреймворка Gstreamer, позволяющая нарушителю выполнить произвольный код.

Описание уязвимости: Уязвимость функции gst_avi_demux_invert мультимедийного фреймворка Gstreamer вызвана целочисленным переполнением. Эксплуатация уязвимости может позволить нарушителю выполнить произвольный код
Уязвимое ПО: Операционная система Red Hat Inc. Red Hat Enterprise Linux 6 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Debian GNU/Linux 10.0 | Операционная система Canonical Ltd. Ubuntu 20.04 LTS | Операционная система Canonical Ltd. Ubuntu 16.04 ESM | Операционная система Novell Inc. OpenSUSE Leap 15.3 | Операционная система Debian GNU/Linux 11.0 | Операционная система Novell Inc. OpenSUSE Leap 15.4 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 9 | Прикладное ПО информационных систем Сообщество GStreamer Gstreamer до 1.20.3 | Операционная система АО «НППКТ» ОСОН ОСнова Оnyx до 2.6 |

Наименование ОС и тип аппаратной платформы: Red Hat Enterprise Linux 6 | Red Hat Enterprise Linux 7 | Ubuntu 1804 LTS | Red Hat Enterprise Linux 8 | Debian GNU/Linux 100 | Ubuntu 2004 LTS | Ubuntu 1604 ESM | OpenSUSE Leap 153 | Debian GNU/Linux 110 | OpenSUSE Leap 154 | Red Hat Enterprise Linux 9 | ОСОН ОСнова Оnyx до 26 |
Дата выявления: 19.07.2022.
CVSS 2.0: AV:L/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,2)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,8)

Возможные меры по устранению:
Использование рекомендаций:
Для Gstreamer:
https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1224

Для Debian GNU/Linux:
https://security-tracker.debian.org/tracker/CVE-2022-1921

Для Ubuntu:
https://ubuntu.com/security/notices/USN-5555-1

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2022-1921.html

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2022-1921
https://bugzilla.redhat.com/show_bug.cgi?id=2130949

Для ОСОН ОСнова Оnyx:
Обновление программного обеспечения gst-plugins-good1.0 до версии 1.14.4-1+deb10u2.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2022-1921.

Тип ошибки CWE: CWE-122, CWE-190
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://ubuntu.com/security/CVE-2022-1921
https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1224
https://lists.debian.org/debian-lts-announce/2022/08/msg00001.html
https://www.debian.org/security/2022/dsa-5204
https://www.suse.com/security/cve/CVE-2022-1921.html
https://safe-surf.ru/upload/VULN/VULN-20220812.9.pdf
https://access.redhat.com/security/cve/CVE-2022-1921
https://bugzilla.redhat.com/show_bug.cgi?id=2130949
https://поддержка.нппкт.рф/bin/view/ОСнова/Обновления/2.6/

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *