Уязвимость BDU:2022-07417

Дата: 15.05.2017. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2022-07417.

Наименование уязвимости: Уязвимость реализации функции xmlSnprintfElementContent() библиотеки libxml2, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость реализации функции xmlSnprintfElementContent() библиотеки libxml2 связана с выходом операции за границы буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 17.04 | Операционная система Debian GNU/Linux 9 | Программное средство защиты IBM Corp. Security Guardium 10.0 | Программное средство защиты IBM Corp. Security Guardium 10.0.1 | Программное средство защиты IBM Corp. Security Guardium 10.1 | Программное средство защиты IBM Corp. Security Guardium 10.1.2 | Прикладное ПО информационных систем Daniel Veillard libxml2 до 2.9.4 | Операционная система Canonical Ltd. Ubuntu 12.04 ESM | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система Debian GNU/Linux 8 | Операционная система Debian GNU/Linux 7 | Прикладное ПО информационных систем Red Hat Inc. JBoss Core Services – | Прикладное ПО информационных систем Red Hat Inc. JBoss Core Services 1 | Операционная система Canonical Ltd. Ubuntu 16.04 ESM | Прикладное ПО информационных систем IBM Corp. App Connect Enterprise Certified Container 4.1 | Прикладное ПО информационных систем IBM Corp. App Connect Enterprise Certified Container 4.2 | Прикладное ПО информационных систем IBM Corp. App Connect Enterprise Certified Container 5.0-lts | Прикладное ПО информационных систем IBM Corp. App Connect Enterprise Certified Container 5.1 | Прикладное ПО информационных систем IBM Corp. App Connect Enterprise Certified Container 5.2 | Прикладное ПО информационных систем IBM Corp. App Connect Enterprise Certified Container 6.0 | Прикладное ПО информационных систем IBM Corp. Cognos Analytics до 11.0.10.0 | Прикладное ПО информационных систем Intel Corp. Manycore Platform Software Stack (MPSS) до 3.8.3 | Программное средство защиты IBM Corp. Security Guardium 10.1.3 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1704 | Debian GNU/Linux 9 | Ubuntu 1204 ESM | Red Hat Enterprise Linux 8 | Ubuntu 1404 ESM | Debian GNU/Linux 8 | Debian GNU/Linux 7 | Ubuntu 1604 ESM |
Дата выявления: 15.05.2017.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:N/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
Для libxml2:
https://gitlab.gnome.org/GNOME/libxml2/-/commit/932cc9896ab

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/cve-2017-9048

Для Debian:
https://security-tracker.debian.org/tracker/CVE-2017-9048

Для Ubuntu:
https://ubuntu.com/security/notices/USN-3424-1
https://ubuntu.com/security/notices/USN-3424-2

Для программных продуктов IBM Corp.:
https://www.ibm.com/support/pages/node/6837647
https://www.ibm.com/support/pages/node/567705
https://www.ibm.com/support/pages/node/868882
https://www.ibm.com/support/pages/node/295723
https://www.ibm.com/support/pages/node/301165
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2017-9048.

Тип ошибки CWE: CWE-119, CWE-121
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://bugzilla.redhat.com/show_bug.cgi?id=1452549
https://gitlab.gnome.org/GNOME/libxml2/-/commit/932cc9896ab
https://access.redhat.com/security/cve/cve-2017-9048
https://security-tracker.debian.org/tracker/CVE-2017-9048
https://ubuntu.com/security/notices/USN-3424-1
https://ubuntu.com/security/notices/USN-3424-2
https://www.ibm.com/support/pages/node/6837647
https://www.ibm.com/support/pages/node/567705
https://www.ibm.com/support/pages/node/868882
https://www.ibm.com/support/pages/node/295723
https://www.ibm.com/support/pages/node/301165
https://nvd.nist.gov/vuln/detail/CVE-2017-9048

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *